Special characters ?

Report any bugs or suspicious behaviour here
Post Reply
lulu
Posts: 8
Joined: 30 Jun 2016, 21:18

Special characters ?

Post by lulu » 01 Jul 2016, 04:48

Hi,

I already use a large number of macros triggered using combinations of regular and modifier keys, so I thought I'd find new combinations using ALT codes characters like

Alt 1 ☺
Alt 2 ☻
Alt 3 ♥
Alt 4 ♦
...
Alt 0254 þ

as the software I want to control is able to recognize them as Key Commands.

But when I script

Code: Select all

lmc_device_set_name('KEYB3', '3B18869E')   
lmc_set_handler('KEYB3',function(button, direction)
  if (direction == 1) then return end  -- ignore down
  if     (button == string.byte('A')) then lmc_send_keys('☺')
  else print('Not yet assigned: ' .. button)
  end
end)
LuaMacros 0.1.0.233 says
"[KEY] ERROR: Invalid KeyName"

Is there a way I can send these special Alt Keys ?

Thanks very much!

admin
Site Admin
Posts: 545
Joined: 01 Nov 2010, 13:00
Location: Prague, Czech republic
Contact:

Re: Special characters ?

Post by admin » 01 Jul 2016, 07:51

lmc_send_keys accept name of a key(s) as parameter (with modifiers like alt, ctrl, shift).
"☺" is not a key - as program says.
So the answer is no - you cannot send those characters as key strokes.
Petr Medek
LUAmacros author

lulu
Posts: 8
Joined: 30 Jun 2016, 21:18

Re: Special characters ?

Post by lulu » 01 Jul 2016, 15:32

maybe in the future :)

Regarding

Code: Select all

lmc_send_keys("^{F10}")
It seems like it sends CTRL then F10 and not CTRL + F10 as in (let's hold CTRL until F10 is pressed) because the software on the receiving end only detects "F10"
Am I missing something ?

Thanks again!

admin
Site Admin
Posts: 545
Joined: 01 Nov 2010, 13:00
Location: Prague, Czech republic
Contact:

Re: Special characters ?

Post by admin » 04 Jul 2016, 07:39

Works for me, what's your "software on the receiving end"?
Some software (games) can read keyboard directly and lmc_send_keys won't work as it should.
Petr Medek
LUAmacros author

lulu
Posts: 8
Joined: 30 Jun 2016, 21:18

Re: Special characters ?

Post by lulu » 04 Jul 2016, 09:24

Steinberg Cubase Pro 8.5
My intuition is that it's a delay issue because I use ATNSOFT KeyManager 1.10 and also have a POS Keyboard with a mix of hardware/software stored Macros, and some encounter this issue when I skip programming the delays.

hummels
Posts: 1
Joined: 21 Nov 2018, 23:07

Re: Special characters ?

Post by hummels » 21 Nov 2018, 23:07

Works for me!
Just wish me luck there. I'm about to read about usopen.golf.com. I've heard it's pretty easy to win there. Isn't it great?

Post Reply