Search found 600 matches

by admin
10 Sep 2019, 09:23
Forum: Bug reports
Topic: LUAMacros Get/SetVariable in XPlane11 doesn't work with Laminar Datarefs
Replies: 4
Views: 31

Re: LUAMacros Get/SetVariable in XPlane11 doesn't work with Laminar Datarefs

Double/single quotes should not play a role.
So I'll try to read "non-standard" variables from some custom plane and see if I have the same behavior.
by admin
09 Sep 2019, 08:46
Forum: Bug reports
Topic: LUAMacros Get/SetVariable in XPlane11 doesn't work with Laminar Datarefs
Replies: 4
Views: 31

Re: LUAMacros Get/SetVariable in XPlane11 doesn't work with Aerosoft Datarefs

LuaMacros plugin uses standard xplane SDk to read/set datarefs. If it works for standards it seems that communication between luamacros (program) and plugin works well. I don't own Aerosoft plane so cannot test myself.
Are you able to read/set these datarefs e.g. in daratef editor plugin?
by admin
23 Aug 2019, 07:21
Forum: HOW-TOs and documentation
Topic: Basic Syntax
Replies: 5
Views: 98

Re: Basic Syntax

The screenshot you have provided is from hidmacros with luamacros code (which will not work of course).
Scripting in hidmacros: http://hidmacros.eu/scripting.php
Scripting in luamacros: http://hidmacros.eu/forum/viewforum.php?f=12
But without scripting knowledge you can't use luamacros.
by admin
13 Aug 2019, 07:54
Forum: HOW-TOs and documentation
Topic: How to send key: (
Replies: 1
Views: 80

Re: How to send key: (

You can't with lmc_send_keys - escaping is not supported for now.
As a workaround you can use lmc_send_input
by admin
06 Aug 2019, 22:04
Forum: Bug reports
Topic: Error when starting?
Replies: 2
Views: 34

Re: Error when starting?

Run as admin for the first time
by admin
06 Jun 2019, 08:09
Forum: HOW-TOs and documentation
Topic: Mouse, display off, url shortcut - Macro questions
Replies: 1
Views: 79

Re: Mouse, display off, url shortcut - Macro questions

ad 1) I think I dropped mouse support in luamacros just for this reason - there were scenarios when I couldn't block the mouse click. So if you're still receiving it there's nothing you can improve on your side ad 2) not by some built-in way. Unless you find some VB script/command to do that ad 3) F...
by admin
03 Jun 2019, 08:08
Forum: HOW-TOs and documentation
Topic: Launch at startup
Replies: 2
Views: 192

Re: Launch at startup

Hidmacros is regular windows application, there should be nothing special.
Just make sure it's startup folder is the one when main exe is stored
by admin
23 May 2019, 08:16
Forum: General
Topic: Lua Macros script not working with Fly with Lua.
Replies: 11
Views: 281

Re: Lua Macros script not working with Fly with Lua.

Then it's just pure debugging of your script. Print the number in the handler and find out, why string.byte gives other number so the if condition doesn't match.
Just lua scripting...
by admin
21 May 2019, 08:41
Forum: General
Topic: Lua Macros script not working with Fly with Lua.
Replies: 11
Views: 281

Re: Lua Macros script not working with Fly with Lua.

Do some debugging then. Try to run xpl command as single line in script - to see if it works.
Try to print debug output from your keyboard handler - too see that "if" command gets executed
by admin
20 May 2019, 08:55
Forum: General
Topic: Lua Macros script not working with Fly with Lua.
Replies: 11
Views: 281

Re: Lua Macros script not working with Fly with Lua.

Try if the xpl communication is working with something simplier. E.g. run script: lmc_log_module('XPL') lmc_xpl_text('From LUA macros') Doest the text appear in xplane? Also you can create empty file lmc_log_file_trigger.log in xplane folder and after doing the test check its content. See some troub...